Critical Notification: Problem Identified. Resolving.

Maintenance
11/20/2025, 8:57am UTC

Critical Notification: Problem Identified. Resolving.

Status: closed
Created: 11/20/2025, 12:48pm UTC
Start: 11/20/2025, 8:00am UTC
End: 11/20/2025, 8:04am UTC
Duration: 4 minutes
Affected Components:
US26177 Planning and Monitoring Job Management API Connectivity Agent Management Web Connectivity
Update

11/20/2025, 8:00am UTC

11/20/2025, 8:00am UTC

We have successfully identified the cause of this service disruption and are working to resolve it. We are expecting to finish within an hour.

Resolved

11/20/2025, 8:04am UTC

11/20/2025, 8:04am UTC

Your tenant is now available.

Update

11/20/2025, 8:28am UTC

11/20/2025, 8:28am UTC

We have finished fixing the affected components and are restarting your tenant. We should be finished in about 10 minutes.

Update

11/20/2025, 8:57am UTC

11/20/2025, 8:57am UTC

We are still resolving the problem affecting your tenant and expect to finish in 15 minutes.