Maintenance Planned
Maintenance
in progress
8 days 7 hours 4 minutes
04/01/2025, 8:00am UTC
Maintenance Planned
Status: in progress
Start:
04/01/2025, 8:00am UTC
Estimated Duration: 120 minutes
Affected Components:
US12598
Planning and Monitoring
Job Management
API Connectivity
Agent Management
Web Connectivity
Update
04/01/2025, 8:00am UTC
04/01/2025, 8:00am UTC
An update on your tenant has been scheduled. The duration of the update process is approximately 2 hours. You will receive notifications before and after the update.