Critical Notification: Problem Identified. Resolving.

Maintenance in progress 24 days 20 hours 11 minutes
03/10/2025, 8:01am UTC

Critical Notification: Problem Identified. Resolving.

Status: in progress
Start: 03/10/2025, 8:00am UTC
Affected Components:
US03730 Planning and Monitoring Job Management API Connectivity Agent Management Web Connectivity
Update

03/10/2025, 8:00am UTC

03/10/2025, 8:00am UTC

We have successfully identified the cause of this service disruption and are working to resolve it. We are expecting to finish within an hour.

Update

03/10/2025, 8:01am UTC

03/10/2025, 8:01am UTC

We are still resolving the problem affecting your tenant and expect to finish in 15 minutes.